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Centralized Startup Guide

This guide is for system administrators who use NCD ThinPATH 
Manager to configure NCD ThinSTAR terminals from a central 
location.

The instructions in this guide assume that you have completed the 
following tasks:

■ Installed NCD ThinSTAR Operating Software and 
NCD ThinPATH Manager as described in the NCD ThinSTAR 
Operating Software and NCD ThinPATH Manager Installation 
Guide. 

■ Set upgrade policies as described in NCD ThinSTAR Operating 
Software and NCD ThinPATH Manager Installation Guide.

■ Installed the necessary SNMP components as described in the 
NCD ThinPATH Manager Release Notes.
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Introduction to Centralized Startup
NCD ThinPATH Manager brings terminal configuration to a central 
location, a Management Server. With its functionality, you can 
configure terminal properties and create connections on the server, 
make the configuration available to terminals, and restart terminals 
to upgrade their configurations—all from one location.

Features of NCD ThinPATH Manager
NCD ThinPATH Manager centralizes NCD ThinSTAR terminal 
management, giving you the following capabilities:

■ Configuring groups of terminals from a central location

Using the Configuration Tool, you can:

— Define groups of terminals.

— Configure terminal properties and connections for groups 
and save values in a .tcf configuration file.

— Register the configuration file with the Management Server 
for automatic terminal updates.

■ Restarting groups of terminals from a central location

When a terminal restarts, it is updated with values from the 
registered configuration file.

■ Configuring SNMP updates, if desired

If you use SNMP to manage terminals, you can configure some 
terminal properties through SNMP. You can use both SNMP and 
NCD ThinSTAR Terminal Properties to configure terminals.

■ Configuring individual terminals from a web browser

This provides a way of managing individual terminals remotely.

Overview of the Central Configuration Process
To configure NCD ThinSTAR terminals through NCD ThinPATH 
Manager, you will complete the following tasks:

■ Getting started
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— Build a list of terminals

— Start the Configuration Tool

— Create a .tcf configuration file

■ Organizing and configuring terminals

— Create terminal subclasses

— Define terminal properties—global properties for all 
terminals and specialized properties for terminal subclasses

— Create connections for terminal subclasses

— Configure SNMP updates, if using SNMP to manage 
terminals (optional)

■ Distributing the new configuration

— Save and register the configuration file with the Management 
Server for automatic terminal updates

— Restart terminals to update them with the new configuration

■ Completing ongoing processes

— Distribute new software to terminals, including 
configuration settings, Operating Software, or client software

— Close all connections running on terminals

— Configure terminals via a web browser

— Reset passwords

This guide has instructions for configuring and starting terminals 
from the Management Server. A companion to this guide, the 
NCD ThinPATH Manager Reference, has details about the 
Configuration Tool, the Remote Restart Tool, and the Web 
Configuration Tool. It also has information about SNMP, 
troubleshooting, and error messages.
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Getting Started
When getting started with NCD ThinPATH Manager, the first steps 
include:

■ Deciding how to configure terminals

■ Starting the Configuration Tool

■ Creating a configuration file

■ Configuring global settings, including assigning terminals to a 
Management Server

■ Registering the configuration file with the Management Server

■ Starting the NCD ThinSTAR terminals to associate them with the 
Management Server and to generate a Managed Terminals List

These first steps lay the groundwork for configuring groups of 
terminals.

Deciding How to Configure Terminals
When you set up a centralized configuration for an NCD ThinSTAR 
network, you define groups of terminals, set properties for them, 
and save and register the configuration file on the Management 
Server. When the terminals associated with that Management Server 
are restarted, they receive the configuration file.

In planning the configuration, keep in mind the following basic 
parameters:

■ You can configure terminals with the Management Server on 
their subnet (the default), or configure terminals with a specified 
Management Server on another subnet.

■ You can create more than one configuration file, but you can only 
register one with the Management Server. If you register a new 
file, the previous one is no longer registered.

■ You can define global settings that apply to all terminals 
associated with a Management Server, then create more 
specialized settings for groups or individuals. 
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The global settings form one general class; groups and 
individuals form subclasses under the global class and their 
settings override the global settings. You may want groups for 
departments or locations, and these groups may require different 
levels of configuration support. You may want individual 
subclasses for special cases.

■ You can choose how many configuration options to make 
available to users.

— You can do a basic configuration that makes standard 
properties and some connections available to users, but lets 
them make changes on their own terminals.

— You can remove specific configuration options from users.

— You can remove all configuration options from users.

The following sections show how to implement these decisions 
through NCD ThinPATH Manager.

Starting the Configuration Tool
You define groups of terminals and configure terminal properties for 
them on the Management Server, using the NCD ThinPATH 
Configuration Tool.

To start the Configuration Tool, select Start > Programs > 
Administrative Tools (Common) > NCD ThinPATH Manager > 
ThinPATH Configuration Tool.

Creating a Configuration File
The Configuration Tool presents options for working on a 
configuration file.

To create a configuration file:

1. Select New Configuration Settings.

Note After you have created and registered a configuration file, 
you can select Open Registered Configuration. Only one 
file can be registered at a time, but you can have more 
than one configuration file. If you create multiple files, 
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you can select Open Configuration Settings and browse 
for the file you want.

2. Select File > Save As, name it, and save it. The file extension 
is .tcf.

Don’t register the new file yet; as soon as a file is registered, it is 
available to terminals.

Configuring Global Settings
The configuration principle of NCD ThinPATH Manager is that you 
can use the Configuration Tool to override values on terminals. You 
can use the tool to set values at the global level, then refine them for 
groups of terminals.

The global class applies to all the terminals the Management Server 
supports. It is named after the configuration file, here mt-hood.tcf.
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As you prepare the configuration file, only include terminal property 
settings for the parameters you want to change. Do not define 
settings for parameters with acceptable default values.

Configure the global settings that apply to all of the terminals, then 
change settings as needed for specific groups of terminals, called 
subclasses. The group changes override global settings.

As you change settings, you will notice an asterisk on the tab label 
(for example, Display*). This shows that you have set or changed 
settings, but have not yet saved them.

Specifying a Management Server

Assign each terminal to a single Management Server.

One Management Server per Subnet

By default, terminals broadcast for the Management Server on their 
local subnet. If you have one Management Server for each subnet, 
you do not need to assign a Management Server.

One Management Server for Multiple Subnets

If one Management Server is to support multiple subnets, the 
recommended practice is to bring the terminals onto the local subnet 
and define the Management Server when making global settings.

To assign a Management Server:

1. Select Management > Server and check that you want to include 
the information.

2. Select NCD ThinSTAR Management Service and enter the IP 
address of the Management Server.

Later, after you restart the terminals, they will receive the 
configuration file that assigns the specified Management Server to 
them. At that point, you can move them to their own subnets.

Note See Using a Management Server Outside the Local Subnet on 
page 11 for another way to specify the Management Server.
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Multiple Management Servers on One Subnet

NCD does not recommend multiple installations of NCD ThinSTAR 
Operating Software on the same subnet. If the Operating Software is 
installed multiple times on the same subnet, any of those 
Management Servers may send new software or a configuration file 
to any terminal. Similarly, terminals may be managed by a different 
server each time they restart. The only reasons to install 
Management Servers on one subnet are:

■ You have many (more than 100) NCD ThinSTAR terminals on 
your subnet.

■ Your Management Server has inadequate system resources to 
support multiple simultaneous software upgrades.

If you feel that multiple Management Servers are needed on the 
same subnet, please contact NCD Technical Support. They can assist 
you with planning and implementing the installation.

Setting Terminal Startup Options

When a terminal starts, it goes through a series of wizards to 
establish basic terminal property options and create a connection. 
Since you are configuring terminals centrally, terminals can skip the 
setup wizard.

To skip the setup wizard:

1. Select Extensions > TSWizard Display and check that you want 
to include the information.

2. Click Configure, choose whether to omit all or part of the 
wizards, and click OK.

Setting Up Security

The Security tab allows you to protect terminal configuration. You 
can:

■ Set and change passwords on the Change Password tab.

■ Enable or disable user changes to Terminal Properties on the 
terminal on the Security > Terminal Properties Access tab.
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Read-only tabs appear grayed out in Terminal Properties.

■ Disable the F2 key to prevent access to Terminal Properties on the 
Terminal Properties Enable tab.

You can use the Management > Clients > Options tab to hide the 
Configure tab in the Connection Manager so it is not possible to add, 
change, or delete connections at terminals.

Defining One Connection

If you define at least one connection globally, you do not need to 
define a connection when a terminal starts.

To define a connection:

1. Select Connections > Configure and check that you want to 
include the information.

2. Click Add, complete the information to add the connection, and 
click OK.

Configuring Other Global Settings

If there are values that you want to set for all terminals, you can 
configure those settings now as well.

Saving and Registering the Configuration File
Now that you have your basic global settings, save and register the 
configuration file with the Management Server. The Management 
Server downloads the registered file to the NCD ThinSTAR 
terminals when they restart.

To save and register the configuration file:

1. Select File > Save and save the file.

2. Select TMS > Register Current Configuration to register the 
current configuration file.

Note The option is on the TMS menu because TMS is the utility 
that downloads the file to the NCD ThinSTAR terminal.
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Another way to register the current file is to select File > Save As, 
check Register this Configuration with TMS, and give a filename.

You can register only one configuration file with the Management 
Server at a time. Later, if you have multiple configuration files, you 
can select TMS > Register Configuration and select any saved 
configuration file.

After you have configured terminals, you may want to select 
Remove Registration so that terminals no longer receive a new 
configuration file when they restart. You may also want to do this if 
you are experimenting with configuration settings. 

Assigning Terminals to a Management Server
You have registered a configuration file with global settings, so you 
can start the NCD ThinSTAR terminals to associate them with the 
Management Server.

Using the Management Server on the Local Subnet

By default, when a terminal starts, it contacts the Management 
Server on its subnet. At that time, the Management Server adds it to 
the Managed Terminals List, which lists the terminals it supports.
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Using a Management Server Outside the Local Subnet

If you want a terminal to use a Management Server on another 
subnet, define it in Terminal Properties.

To choose a Management Server for software updates:

1. Go to the terminal and press F2 to start Terminal Properties.

2. In Terminal Properties, select Management > Server.

3. Enter the IP address of the Management Server that is to update 
the Operating Software on this terminal, then click Apply, then 
OK.

If name resolution service is available, you can use the host 
name. If you have specified a gateway, you can specify the 
Management Server on a different subnet.

4. Restart the terminal.
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Removing a Terminal from the Managed Terminals List

The list is generated automatically and you should not need to edit it 
when you first get started. You may need to edit at some point 
during the process.

You do not need to edit the list if a terminal’s IP address changes; the 
Management Server detects the change and updates the list.

You must edit the list if you remove a terminal. You can also add 
terminals to the list or change information.

To delete a terminal:

1. Select Utilities > Remote Restart Tool.

2. Select Edit > Delete.

3. To delete one or more terminals from the list, select them and 
click Delete.

Note Only delete a terminal from the list after it is removed 
from the network. If the terminal is still on the network, it 
is added to the list when the terminal starts.

4. When finished, click Close.

Organizing and Configuring Terminals
A configuration begins with a global class that applies to all 
terminals. After defining global settings, you can refine properties 
and create connections for groups of terminals. These groupings are 
called subclasses, and they contain one or more terminals.

Creating Subclasses

You may want to create subclasses for departments, locations, or 
special requirements. In the following example, the mt-hood.tcf 
configuration file has subclasses for two departments—Sales and 
Human Resources, and one individual terminal, identified here by 
its serial number.
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You can place a terminal in more than one subclass, then use the 
order of the subclasses to establish final properties for it. Moving 
down the list overrides any properties set before. The global settings 
always remain at the top of the list, but you can move subclasses up 
or down. To change the order, click a subclass and drag it or right 
click a subclass and select Move Up or Move Down.

The mt-hood.tcf 
configuration file 
has three 
subclasses.
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The subclass information you enter is as follows.

To create a new subclass:

1. Select Subclass > New.

2. Enter information for the subclass and click OK.

— Subclass Name

For a subclass of one (an individual subclass), enter the 
terminal’s IP address, hardware address, or serial number. 
With DHCP dynamic IP addresses, it is better to identify the 
terminal by its hardware address or serial number.

— Group Subclass/Individual Subclass

Select group for a subclass with multiple terminals or 
individual for a subclass with one terminal.

— After Current Subclass/Before Current Subclass

Choose where to position the new subclass in the list.

A group requires at least one member, as described next.

This group has a 
range of IP addresses.

Basic information is 
required for group and 
individual subclasses.



NCD ThinPATH Manager Centralized Startup Guide 15

Organizing and Configuring Terminals

Adding Members to a Subclass

Assign at least one member to the subclass. You can add members 
manually or import a text file.

Adding Members through the Configuration Tool

You can add members through the Configuration Tool, identifying 
them by IP address, hardware address, or serial number.

With NCD ThinSTAR Operating Software version 2.0 and later, the 
Management Server collects and updates IP address, hardware 
address, and serial numbers when it downloads software to a 
terminal. It adds the terminal to a Managed Terminals List and you 
can use the list to select terminals for remote restarts or subclasses.

To add information:

1. Click Add.

The group subclass has a range 
of IP addresses.

You can add members through 
the Configuration Tool or import a 
list of members from a text file.
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2. Enter information to identify terminals and click OK. If you have 
restarted terminals, they belong to the Managed Terminal List, so 
you can add from that.

You can identify terminals by IP address, hardware address, or 
serial number.

— IP addresses

The standard IP address has a dotted decimal format (four 
decimal values separated by dots). In an IP address range, 
you can vary only the value in the last octet (the fourth field) 
and you cannot include leading zeroes. For example, 
192.45.85.6 is a member of the range indicated by 192.45.85.1 
through 192.45.85.10. This is called a Class C subnet.

If you are using dynamic IP addresses assigned by DHCP, 
group terminals by their hardware address or serial number. 
With IP addresses you wouldn’t know which terminal 
received a given configuration file.

— Hardware (MAC) address

The standard MAC or hardware address, sometimes called a 
network address, has the following format:

xx:xx:xx:xx:xx:xx

where x represents a hex digit 0–9, A–F. For example: 
00:00:A3:08:12:7C.

This address is on the terminal; to see it, go to NCD 
ThinSTAR Terminal Properties and select Inventory > 
Network Settings > Address.

You can specify a hardware address range, varying only the 
values in the last three fields (the last six values).

— Serial number

The serial number is assigned to a terminal at the factory and 
is on the terminal; to see it, go to NCD ThinSTAR Terminal 
Properties and select Inventory > Hardware.
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The following example shows that terminals are to be 
identified by their IP address; the range of IP addresses for 
terminals on one subnet is entered.

If terminals had been started, they would appear on the 
Managed Terminals List and you would be able to select 
from the list. To select multiple members, click one address 
and press Shift + click to select a continuous block, or press 
Ctrl + click to select members one by one.

Importing a List of Terminals

You can add subclass members by importing a list of terminals 
exported from a source such as a database or a UNIX /etc/hosts file.

To import members:

1. In the NCD ThinPATH Manager Configuration Tool, select the 
group subclass, then select Subclass > Import Members.
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2. Enter the name of the text file, then click Import, then select 
options for delimiters and click OK.

3. Select File > Save to save the file.
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Viewing a Member List

If your members have consecutive ranges of IP addresses, hardware 
addresses, or serial numbers, you can view the ranges or expand the 
list to show all members.

Removing Information

You can remove members or entire subclasses.

Removing Members

Removing terminals from a subclass deletes them from the subclass 
when you save the configuration file.

Collapsed list Expanded list
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To remove members from a subclass:

1. Select the subclass then select Subclass > Edit (or double click on 
the subclass name).

2. Select the member(s) and click Remove.

Selection options include:

— Only one member

Click on a member in an expanded list.

— Multiple members

Use the Ctrl or Shift key or drag the mouse.

— All the members of a range

Click on a range in a collapsed list.

3. Save the configuration file.

Removing a Subclass

Removing a subclass deletes it and its configuration values from the 
configuration file when you save the file.

To remove a subclass:

1. Select the subclass name, then select Subclass > Delete or press 
Delete and confirm that you want to delete it.

2. Save the configuration file.

Configuring Terminal Properties
Terminal properties are configuration values for NCD ThinSTAR 
terminals. You can set most of the properties through 
NCD ThinPATH Manager.
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Terminal Properties and NCD ThinPATH Manager

On an NCD ThinSTAR terminal, terminal properties are available on 
a set of tabs. NCD ThinPATH Manager presents a similar series of 
tabs, plus a tab for connections.

Using the NCD ThinPATH Configuration Tool, you can define 
settings on property tabs as follows:

■ General — identifies the product. (On the terminal, this tab 
provides an option for resetting all configured values to factory 
defaults.)
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■ Input — has settings for the keyboard and the mouse.

■ Display — has settings for the monitor, including resolution, 
refresh rate, a screen saver and highcolor.

■ Network — has basic settings for network addresses. Parameters 
that cannot be set globally, such as a static IP address, are on 
terminals but are not in NCD ThinPATH Manager.

■ Security—has password protection and access options.

■ Management — has additional tabs with settings for pointer 
speed, audio, server, hotkeys, network, power, and clients.

Pointer lets you set pointer speed for the mouse.

Audio has sound options.

Server lets you assign a Management Server.

Hotkeys allows Up and Down hotkey combinations to bring 
forward the next active or previous active session.

Network provides additional networking options and includes 
diagnostics.

Power has a timeout setting that governs the terminal (not the 
monitor) power saving mode on terminals that support it. 
NCD ThinSTAR 200 terminals do not support it.

SNMP has options for SNMP configuration. Terminal Properties 
on a terminal does not include this.

Clients has the global client settings, if supported; they are not 
supported for the Microsoft Terminal Server Client. You can also 
enable or disable access to the NCD ThinSTAR Connection 
Manager Configure tab.

System has startup options for Num Lock, Caps Lock, and Scroll 
Lock.

Precedence

Global configuration settings are applied first, then subclass changes 
are applied, starting at the top of the list and ending with the bottom 
of the list. The settings at the bottom of the list have the greatest 
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precedence. If a terminal belongs to more than one subclass, the 
settings in its lowest subclass take precedence.

When the terminal restarts, settings in the NCD ThinPATH Manager 
configuration file override terminal properties that were changed at 
the terminal. You can specify whether connections in the registered 
configuration file overwrite connections defined at the terminal.

Defining Properties for a Subclass

When defining properties for a subclass, include only the settings 
you want to change. There is no need to define and save settings for 
parameters that have acceptable default values.

Default Terminal Properties

The default property settings on an NCD ThinSTAR terminal are as 
follows.

Factory Default Property Settings

Tab Attribute Default Setting

Input Keyboard English (United States).

Mouse Right-handed.

Character Repeat The shortest delay; midway between the fastest and 
slowest rate.

Display Desktop Area and 
Refresh Frequency

Best Available Using DDC.

Screen Saver Enabled, with a timeout of 20 minutes.

HighColor Disabled.

Network IP Address Get an address from a DHCP server. Existing IP 
address entries are removed.

Advanced

Network

Enable DNS Filled with data from DHCP.

Enable WINS Filled with data from DHCP.
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Security Password No password.

Management Pointer Speed Four units above slow.

Audio High volume.

Microphone disabled (microphone not available on 
NCD ThinSTAR 200 or 250).

Touchscreen Disabled.

Server Blank.

Hotkeys Enabled.

Network LAN connection; network speed is sensed 
automatically.

DHCP timeout of 60 seconds; Management Server 
timeout of 5 seconds.

Host resolution timeout of 5 seconds. Send count of 
5.

Power No settings.

Clients Microsoft Terminal Server Client.

English (United States) locale.

Configure tab of Connection Manager enabled.

Extensions Terminal identification none

Wireless DHCP (available only on the NCD ThinSTAR 400 
series)

IE Browser Disabled.

Inventory Network information Reports IP address changes caused by reset to 
defaults on Network tab and Display tab.

Factory Default Property Settings (continued)

Tab Attribute Default Setting
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Creating Properties for a Subclass

To include properties for a subclass:

1. Select the subclass.

2. On the appropriate tab, check the box to include properties.

3. Change the settings.

Descriptions for the settings are in online help. If you decide to 
restore included parameters to default settings, click the Default 
button.

4. Select File > Save to save the configuration file.

Configuring Connections
You can create global connections for your NCD ThinSTAR terminals 
using the Configuration Tool. On the Connections tab, you can:

■ Set up connections. 

■ Limit the number of connections running on the terminal.

■ Remove connections. 

The Connections > Configure tab has wizards for adding 
connections for installed clients, such as Microsoft Terminal Server 
Client and ICA. They are similar to the wizards on the terminal. 
Three clients, two with their own communication protocol, provide 
connects:

■ Microsoft Terminal Server client connections

The Microsoft Terminal Server client uses the RDP protocol to 
connect to a Windows Terminal Server.

■ Citrix ICA connections

The Citrix ICA client uses the ICA protocol to connect to a server 
running Citrix WinFrame or to a Windows Terminal Server 
running Citrix MetaFrame.

■ Microsoft Internet Explorer connection
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Terminals can connect to the internet using the Microsoft Internet 
Explorer browser.

Additional client libraries are available from NCD to support other 
types of connections, including those for terminal emulators, 
X Windows, and load balancing.

Defining Global Connections

To define global connections for Microsoft Terminal Server client, 
Citrix ICA client and other NCD clients:

1. Select Connections > Configure.

2. Click Add. The New Connection dialog displays.

3. Complete the wizard.

Connecting Terminals to the Internet Using Microsoft Internet 
Explorer 

To allow an Internet Explorer session on multiple terminals:

1. On the Extensions tab, select Include Extensions page settings in 
configuration.

2. Double-click IE Browser in the list of extensions.

3. Click Enable Web Connection. This allows a Web connection to 
appear in the terminal’s NCD ThinSTAR Connection Manager. 
Only one Web connection per terminal is allowed.

4. Change browser preferences as appropriate. See the NCD 
ThinSTAR Terminal User’s Guide for explanations of available 
options.

Removing Defined Connections

This procedure removes all connections of a specific type. It is 
recommended that you first remove all defined connections in order 
to create a clean state.

To remove all connections of a specific type:

1. Select Connections > Remove.
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2. Check the Remove all connections of type checkbox.

Configuring Terminals with an SNMP Agent
If you configure terminals with SNMP alone or along with the 
Configuration Tool, you can distribute part of the settings through 
NCD ThinPATH Manager.

An SNMP agent is installed on an NCD ThinSTAR terminal as part 
of the Operating Software. By default, it is read-only and the values 
it can read are in the NCD-THINSTAR.MIB.txt file, which is installed 
in the ...\NCD\ThinSTAR Management directory.

If an SNMP manager is installed on the Management Server, it 
receives data about property settings from the SNMP agent on the 
terminal.

You can include settings for SNMP updates in the NCD ThinPATH 
Manager configuration file. After a terminal restarts and receives the 
new configuration file, you configure the SNMP agent on the 
terminal to allow SNMP updates from the specified SNMP manager.

You also configure the SNMP agent on the terminal to send a trap 
message to the SNMP manager on the Management Server when the 
terminal restarts or when changing terminal property settings on the 
terminal fails.

Traps for these occurrences are available on the Management > 
SNMP > Send Traps tab:

■ Cold Restart

This notifies the system administrator that someone has restarted 
the terminal. The SNMP agent on the terminal sends a message 
to the SNMP manager on the Management Server when a 
terminal restarts.

■ Authentication Failure

This notifies the administrator that someone lacking 
administrative privileges may be trying to change terminal 
properties. The SNMP agent on the terminal notifies the SNMP 
manager on the Management Server when authentication fails.
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Distributing a Configuration File
At this point in the process outlined in this startup guide, the 
configuration file is ready for distribution to the terminals.

You can use the Remote Restart Tool to distribute the configuration 
file automatically. The following steps explain how to select 
terminals and choose a restart method. The Management Server 
restarts the selected terminals automatically.

To select and restart terminals:

1. Start the Remote Restart Tool.

Select Start > Programs > Administrative Tools (Common) > 
NCD ThinPATH Manager > NCD ThinPATH Remote Restart 
Tool or start the Configuration Tool and select Utilities > Remote 
Restart Tool.

2. Select a restart method and options. 

Choose a restart option with Tools > Restart Terminals or 
schedule a restart with Tools > Schedule Restart.

— Restart Terminals

Select terminals and click OK, then choose a restart option 
and click OK.
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The restart options are as follows.

Restart Option Description

Restart Immediately Each terminal restarts immediately, even if there are open 
connections.

If the Windows Terminal Server is configured to disconnect when 
a connection breaks or times out, terminals can reconnect to 
sessions that were interrupted. All applications that were running 
when the session disconnected resume the next time the user 
logs on.

If the Windows Terminal Server is configured to reset when a 
connection breaks or times out, any unsaved work is lost when 
the session ends.

For more information, see the Administrator’s Guide for Microsoft 
Windows 2000 or Microsoft Windows NT Server, Terminal Server 
Edition.

Restart Pending Each terminal restarts automatically after the last connection on 
that terminal is closed.

Wake on LAN A network message powers up NCD ThinSTAR 300, 300TR, or 
400 series terminals. NCD ThinSTAR 300 and 300TR terminals 
must have their rear power switch on (set at 1) to respond to this 
message and restart.

Detect The Management Server pings the terminal.

Delay If you are restarting multiple terminals, set the delay to define the 
interval between consecutive terminal restart attempts.
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— Schedule Restart

Select terminals and click OK, then schedule the restart and 
click OK.

If you are restarting multiple terminals, set the delay to 
define the interval between consecutive terminal restart 
attempts.

If you want to create a log of terminals that restart, click 
Generate Report and enter a name for the log file.
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3. Check the restart status displayed.

Statuses are as follows.

If some terminals cannot restart, save time by cancelling the 
restart for them. To do this, select the terminals and click 
Cancel. As soon as the command succeeds or times out on the 
current terminal, the restart is cancelled for the remaining 
terminals.

Status Explanation

Trying Restart A restart command was sent to the terminal. The software is trying to 
restart the terminal. This value appears momentarily.

Restarting The terminal is restarting. This status only appears when the terminal 
receives a restart command from the Remote Restart Tool; it does not 
appear when a terminal is physically restarted.

Restart Pending The terminal is waiting for all terminal connections to close before 
restarting.

Not Responding The terminal did not respond before the restart command timed out.

ThinSTAR 200 terminals that do not restart receive the “Not 
Responding” status in the terminal list after the command times out, so 
the terminal is probably not powered on.

ThinSTAR 300, 300TR, and 400 series terminals that do not restart are 
sent a Wake-on-LAN command. If they were turned off using the front 
power switch, the ThinSTAR 300 terminals wake or power up and 
restart. If the ThinSTAR 300 terminals do not respond to the Wake-on-
LAN command, the power switch on the back of the terminal is probably 
in the Off position, so a remote restart is not possible and the terminal’s 
status remains Wake-on-LAN.

Wake-on-LAN The terminal received a Wake-on-LAN command and the Remote 
Restart Tool is waiting for the terminal to restart.

Detected Terminal The terminal responded to a ping packet.
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Ongoing Processes
After your terminals are set up initially, there are ongoing processes, 
such as:

■ Distributing new software to terminals, including configuration 
settings, Operating Software, or client software

■ Closing all connections running on terminals

■ Configuring terminals via a web browser

■ Resetting passwords

Distributing New Software or Configurations to Terminals
Any time you need to update software or terminal configurations, 
the process is the same:

■ Install new software, if any, on the Management Server.

■ Open the configuration file or create a new one.

■ Set properties or create connections.

■ Save the configuration file.

■ Register the configuration file, if it is a different one.

■ Restart terminals.

Closing All Connections Running on Terminals
If you need to close all connections running on the terminals, you 
can do it with the Remote Restart Tool.

Configuring Terminals with the Web Configuration Tool
With a compatible web browser, you can use the NCD ThinPATH 
Web Configuration Tool to view and set most, but not all, of the 
terminal properties of an NCD ThinSTAR terminal from any 
location. Netscape 4.0 and Microsoft Internet Explorer 4.0 are 
compatible browsers.
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The path to this tool in NCD ThinPATH Manager is Utilities > 
Tools > Web Configure.

Prerequisites

The ThinPATH Web Configuration Tool must be installed on the 
terminal before you can configure the terminal with a web browser. 

After the tool is installed on the terminal, you need the terminal’s IP 
address and password. If password protection has not been set up on 
the terminal, the terminal property settings are displayed in read-
only mode so you cannot change any terminal property settings. 
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Reconfiguring the Terminal

If the password protection is set up and you enter the correct 
password, you can use the Web Configuration Tool to reconfigure 
the terminal.

To configure terminal properties using a web browser:

1. Start your web browser. 

Note Use Netscape 4.0 or later or Internet Explorer 4.0 or later.

2. Enter the URL of the NCD ThinSTAR terminal in the Location or 
Address entry area of the web browser and press Enter.

For example, if the IP address of a terminal is 172.31.0.12, its URL 
would be http://172.31.0.12. (On most browsers, if you enter the 
IP address, the browser automatically changes it to the correct 
URL.)

3. If the terminal has password protection, enter the password.

If the terminal lacks password protection, you can see properties, 
but you cannot modify them.

4. Set properties.

Note If you click Defaults on the General tab, you are asked to 
confirm that you want to restart the terminal. If you 
confirm the restart, open connections are terminated and 
you may lose unsaved work in open applications.

5. Modify the settings and click Apply. The new settings are sent to 
the terminal. Changes to most terminal properties take effect 
immediately, but changes to network settings take effect after the 
terminal restarts.

6. Click Restart Terminal if you want to restart the terminal 
immediately.

Restarting a Terminal Over the Web

For most terminal properties, you do not need to restart terminals 
after changing a setting because the change occurs immediately. 
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However, the following changes, which are related to network 
settings, take effect after the terminal restarts:

■ IP address

■ Subnet mask

■ Gateway

■ Advanced network settings

To restart the terminal to put new properties into effect:

1. Start your web browser.

2. Enter the URL for the NCD ThinSTAR terminal, for example, 
http://172.31.0.12.

3. Click Restart Terminal.

4. Close the web browser.

Resetting Passwords
If you know a terminal’s password, you have two options for 
changing it:

■ You can use the Web Configuration Tool to change a password 
over the web.

■ You can go to Terminal Properties on the terminal and set the 
password on the Security tab.

If a terminal does not have password protection, you can use the 
Configuration Tool to create a subclass of one terminal and reset the 
password for it.
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